Come Utilizzare la Funzione CERCA VERT in Excel

La funzione Cerca.vert cerca un valore all’interno della prima colonna di una tabella, che sia uguale o più vicino possibile al valore che abbiamo indicato, e restituisce il valore corrispondente (della stessa riga di quello trovato).

La sintassi della formula è abbastanza complessa: =CERCA.VERT(valore;matrice_tabella;indice;intervallo) dove: valore è la cella di riferimento dove abbiamo il valore da cercare; matrice_tabella è la tabella dentro la quale dobbiamo trovare il valore (che sarà ricercato nella prima colonna della tabella); indice è il numero di colonna della tabella dove vi è il valore corrispondente che vogliamo sia restituito; intervallo può essere Falso o Vero, nel primo caso deve trovare il numero preciso del valore da cercare altrimenti restituisce un errore, nel secondo caso restituisce il numero che più si approssima a quello del valore cercato.

Se per esempio cerchiamo il nome del cliente che corrisponde al numero di codice indicato nella cella F1, che sia all’interno della colonna da A1 ad A10 di una tabella, dovremo scrivere la formula: =CERCA.VERT(F1;A1:D10;2;VERO) dove: Cerca.vert è la corretta sintassi della funzione; F1 è la cella dove abbiamo inserito il valore del codice da ricercare; A1:D10 è l’intervallo di celle della tabella in cui ricercare il valore di F1; 2 è il numero di colonna della tabella, partendo da sinistra, dove vi sono i nomi corrispondenti ai numeri di codice; Falso richiede un’esatta corrispondenza fra valore ricercato e valori presenti nella colonna in esame altrimenti restituisce un errore. Se avessimo utilizzato Vero al posto di Falso avrebbe ricercato il valore più vicino (in ordine ascendente).

Facciamo un esempio concreto: nella colonna A abbiamo i nomi di quattro persone, nella colonna B l’età corrispondente ad ognuno di loro, in D4 inseriamo il nome della persona di cui vogliamo trovare l’età. La formula sarà: =CERCA.VERT(D4;A1:B4;2) dove: D4 è il nome della persona di cui vogliamo conoscere l’età; A1:B4 è la tabella completa dove vi sono i nomi e le età corrispondenti; 2 è la colonna in cui viene cercata l’età; infine è stato omesso il valore finale vero/falso, in quanto la sua omissione risulta come Vero che non richiede un’esatta corrispondenza con il numero richiesto, ma viene scelto quello che più si avvicina ad esso.

Per evitare che quando la cella col valore di riferimento è vuota ci venga restituito l’errore #N/D, potremmo annidare la funzione cerca.vert all’interno di una funzione se in questo modo: =SE(F1=””;””;CERCA.VERT(F1; A1:D10;2;FALSO))

Essa ci dice che se F1 è vuota avremo una cella vuota, altrimenti verrà eseguita la funzione cerca.vert.

Leave a Reply

Your email address will not be published. Required fields are marked *